Главная
/
Документация
/
Пример конфигурации маршрутизатора для Мультикаст-IX с комментариями

Пример конфигурации маршрутизатора для Мультикаст-IX с комментариями

10 июня 2015, 11:48

!
interface Ethernet0
  description M9-MIX
  ip address 194.85.3.XX 255.255.255.0
  no ip directed-broadcast
  no ip redirects
  no ip proxy-arp
  no ip mroute-cache ! отключен fastswitching mcast из-за проблем с IOS
  ip pim sparse-dense-mode
! Информация о наших RP не должна попадать в "чужой" домен
! ни через PIMv2 Bootstrap, ни через AUTO-RP
  ip pim border ! чтобы исключить PIMv2 Bootstrap
  ip multicast boundary 60 ! чтобы ограничить набор групп,
! которыми разрешается обмениваться
! (в т.ч. запрещены группы, участвующие в AUTO-RP)
  ip pim neighbor-filter 20 ! фильтр участников M9-MIX
no shutdown
!
!==============================================================
!
! MSDP
!
ip msdp cache-sa-state list 199 ! кэшировать входящие SA сообщения
!
ip msdp redistribute list 120 asn 1 ! фильтровать исходящие SA
! (разрешать только для разрешенных mcast групп участника MIX)
!
! PEER 1
ip msdp peer 194.85.3.XX
ip msdp description 194.85.3.XX peer1
ip msdp sa-filter in 194.85.3.XX list 121 !фильтр входныx SA
                                           !сообщений от peer
ip msdp sa-request 194.85.3.XX !посылать peer'у SA request,
                                !когда появляются новые слушатели
ip msdp filter-sa-request 194.85.3.XX list 60
                                !отвечать только на те
                                !SA request от данного peer-а,
                                !которые относятся к мультикаст-
                                !группам, описываемым acl 60.
!
! MBGP
!
router bgp YYYY
  neighbor EBGP-MIX peer-group nlri multicast
  neighbor EBGP-MIX send-community
  neighbor EBGP-MIX filter-list 1 out
  neighbor EBGP-MIX prefix-list mix-out out
  neighbor EBGP-MIX weight 100
!
! PEER 1
  neighbor 194.85.3.XX remote-as ZZZZ
  neighbor 194.85.3.XX peer-group EBGP-MIX
  neighbor 194.85.3.XX description peer1
  neighbor 194.85.3.XX filter-list 121 in
!
!
! Этот роутер является Candidate RP для групп,
! описываемых списком 61.
! Об этом он объявляет и по AUTO-RP
! и с помощью PIMv2 Bootstrap
!
ip pim bsr-candidate Loopback0 30 100
ip pim rp-candidate Loopback0 group-list 61
ip pim rp-announce-filter rp-list RP-list group-list 61
ip pim send-rp-announce Loopback0 scope 4 group-list 61
ip pim send-rp-discovery scope 16
!
access-list 60 deny 224.0.1.39 ! список групп, разрешенных для обмена
access-list 60 deny 224.0.1.40
access-list 60 permit 224.2.127.253
access-list 60 permit 224.1.127.255
access-list 60 permit 224.2.127.254
access-list 60 permit 239.0.0.0 0.0.255.255
!
access-list 61 deny   224.0.1.39 ! внутри своего PIM домена анонсируются
access-list 61 deny   224.0.1.40 ! RP для этих групп и роутер для них RP
access-list 61 permit 224.0.0.0 15.255.255.255
!
! фильтр выходных SA сообщений. Разрешить выходные SA сообщения
! для адресов MIX и для объявления групп соседям по sdr.
access-list 120 permit ip any 239.0.0.0 0.0.255.255
access-list 120 permit ip any host 224.1.127.255
access-list 120 permit ip any host 224.2.127.253
access-list 120 permit ip any host 224.2.127.254
!
! входные SA сообщения пропускать только для разрешенных групп.
access-list 121 permit ip any host 224.1.127.255
access-list 121 permit ip any host 224.2.127.253
access-list 121 permit ip any host 224.2.127.254
access-list 121 permit ip any 239.0.0.0 0.0.255.255
!
access-list 199 permit ip any any ! кэшировать все входные SA сообщения
!
ip as-path access-list 1 permit ^(YYYY)?$ ! список AS для анонса по MBGP
!
ip access-list standard RP-list
  deny   XX.XX.XX.XX ! адрес собственной RP участника MIX
  permit any
!
ip prefix-list mix-out permit AA.BB.CC.DD/EE ! сети для обмена по MBGP
ip prefix-list mix-out deny 0.0.0.0/0
!